Today I Swapped My First Motherboard

As you may have read here I managed to mess up my PC`s BIOS, thereby rendering my motherboard useless.

 

On Friday the MFR sent over a brand new motherboard under the warranty.  However, unlike previous times (yes there have been previous times), this motherboard came without a tech.

This presented a number of challenges. Firstly, the serial number of the PC must be updated in the BIOS, which is something the tech is supposed to do. If this is not done, then the user will get an alarming beeping noise and a BIOS error whenever they boot up their PC.

Secondly, and most importantly, is that up to this point I had never changed a motherboard before. Plain and simple.

Don`t let that stop me.

Right off the bat I realized that I did not have an ESD bracelet. No matter, I told myself, as I grounded myself through the PC`s power supply. Next, I noticed that we did not have non-magnetic screwdrivers. Again, no matter, as I decided to risk it using my magnetic drill.

I began by unscrewing the fan and moving the CPU to the new motherboard; Simple enough. Then I began to unplug all of the cables, which brought on the I-won`t-remember-where-the-cables-are-supposed-to-go anxiety, or  IWRWCASTGA for short. Then I unscrewed all 8 or so screws, and took out the board.

The next part should have been a cinch, and initially it was. I placed the new motherboard inside the case, tightened all the screws, and even managed to place all the cables  back in their original one (except for the one that connects the power button to the motherboard).

It was when I was trying to tighten the screws for the CPU fan that I noticed I had a problem. For some reason the screws would not tighten. I looked into the holes where the screws were supposed to go, and I saw nothing. It was like looking into a deep dark abyss. At this point it occurred to me to check the bottom of the old motherboard, and I noticed a bracket holder. So I removed it, and after some more unscrewing, cable removing, and screwing I had my new motherboard all set up and ready to go.

At this point everything should have been peachy keen, but it was not. As you may recall from a few paragraphs back, when a motherboard is replaced, the serial number for the computer must be updated in BIOS. Otherwise, the PC will make an annoying beeping sound at boot and show a BIOS error.

For some reason I was unable to get around this beeping sound. Every time I tried to boot, it would not pick up the OS in the hard drive, and continued looping through PXE. This continued for a bit, until I changed the BIOS to boot in legacy mode. The PC booted all the way to the Windows login in screen…

…but that was as far as it was willing to go. I believe this had something to with the OS not knowing what to do with the new hardware, and causing the hardware abstraction layer to not work properly.

To make a long story short, I re-imaged the PC, and flashed the bios with correct information. And we lived happily ever after.

As a side note, after all this I tried to upgrade this PC to Windows 10 1709 Enterprise from Windows 7 Enterprise (I will write more about this issue a different time), and it worked!

 

Advertisements

One thought on “Today I Swapped My First Motherboard

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s